Error de Actualización de XServer daña aplicaciones en Java

Se ha reportado en Launchpad un bug que envuelve a la última actualización de xserver-xorg-core, la 1.3.0.0.dfsg-12ubuntu8.1.

Esta actualización hace que dejen de funcionar programas gráficos que usan Java, así que tengan cuidado con esta actualización.

Los programas nombrados que son afectados con la última actualización son VLC Player, Eclipse, Jungledisk, aMule, Azureus, entre otros.

Al iniciar desde consola alguno de estos programas, se produce un mensaje que indica que se ha recibido un error desde el sistema X Window.

Aunque yo he probado algunos de estos programas que tengo instalado en mi PC, como VLC y aMule, no me han arrojado errores, a pesar de que yo actualicé el xorg esta mañana, pero a muchas personas en Launchpad sí.

Una solución temporal a este error es hacerle un downgrade al xorg-xserver-core, con alguno de los siguientes comandos:

wget http://launchpadlibrarian.net/9590664/xserver-xorg-core_1.3.0.0.dfsg-12ubuntu8_i386.deb
dpkg -i xserver-xorg-core_1.3.0.0.dfsg-12ubuntu8_i386.deb

Y luego reiniciar las X.

Otra forma es por medio de aptitude:
sudo aptitude install xserver-xorg-core=2:1.3.0.0.dfsg-12ubuntu8
Y luego reiniciar las X.

Cabe resaltar que este downgrade es para las personas que tengan instalado Ubuntu Gutsy 7.10; para soluciones a otras distribuciones, chequeen los comentarios en la página de reporte del bug.

LAUNCHPAD

ACTUALIZACIÓN!!!: Me acaba de llegar la nueva actualización del xorg-server-core, la versión 1.3.0.0.dfsg-12ubuntu8.3, pesa 3.5 megas y es critico que actualicen, ya que se corrigieron multiples fallas de memoria que podrían llevar a inestabilidad del sistema.

Para chequear nuevas actualizaciones en el sistema, digiten en terminal:
sudo apt-get upgrade

Saludos!

3 comentarios to “Error de Actualización de XServer daña aplicaciones en Java”

  1. meneame.net Says:

    Error de Actualización de XServer daña aplicaciones en Java,wxwidgets y wxpython

    Se ha reportado en Launchpad un bug que envuelve a la última actualización de xorg-xserver-core, la 1.3.0.0.dfsg-12ubuntu8.1. Esta actualización hace que dejen de funcionar programas gráficos que usan Java,Wxwidgets y wxpython, así que tengan cuid…

  2. Talie Says:

    Te falta decir que para los que quieran la forma gráfica, se puede hacer un downgrade en synaptic marcando en el menú “Paquete” la opción “Forzar versión” y eligiéndola en el desplegable que sale.

  3. Dr. F.E.A.R. Says:

    Buena alternativa, Talie, muchas gracias por la sugerencia.

    Gracias tambien por leer nuestro blog.

    Saludos!


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: